
Eco 4306 Economic and Business Forecasting
Chapter 11: Forecasting with a System of Equations: Vector Autoregression
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Motivation

I so far, we discussed the modeling and forecasting for a single stochastic process
I univariate ARIMA model: use the time dependence of the stochastic process to

develop a model and produce a forecast
I we successfully applied this approach to various time series such as real GDP,

construction spending, house prices, per capita personal income, interest rates,
labor force participation rate, earnings per share, . . .
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Motivation

I economists develop theoretical economic models - simplified representations of the
economy - with many economic variables interacting with each other
I consumption depending on the level of income
I investment decisions as a function of interest rates
I money supply influencing inflation
I exchange rates linking production of two or more countries

I we will now explore how these kind of interactions can be modeled from an
econometric and forecasting perspective
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Motivation

I we will thus develop multivariate forecasting models to jointly forecast several
time series (e.g. consumption and income)

I we will analyze not only the time dependence in each series, but also the
interdependence between them over time

I we will thus create a system of equations, one equation for each variable, with
much richer dynamics than those contained in each univariate process

I each equation will contain information not just about its dependent variable’s
history but also the history of the other variables in the system

I motivation: with a multivariate information set (e.g. past consumption and past
income) we may be able to construct a better forecast for variables in the system

4 / 30



Motivation

I we will intorduce some new concepts: vector autoregression model (VAR),
Granger-causality, impulse-response functions (IRF)

I vector autoregression models are commonly used to forecast systems of interrelated
time series and to analyze the dynamic impact of random disturbances on the
variables in the system
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11.1 What Is Vector Autoregression (VAR)?

I suppose that we have two processes {Yt} and {Xt}
I a vector autoregression of order p, VAR(p) for {Yt} and {Xt}, is then defined as

a system of two equations where the regressors are the lagged values of {Yt}, {Xt}

Yt = c1 + α11Yt−1 + . . .+ α1pYt−p + β11Xt−1 + . . .+ β1pXt−p + ε1t

Xt = c2 + α21Yt−1 + . . .+ α2pYt−p + β21Xt−1 + . . .+ β2pXt−p + ε2t

I error terms ε1t and ε2t are assumed to be normal random variables with
ε1t ∼ N(0, σ2

1) and ε2t ∼ N(0, σ2
2)

I errors can be contemporaneously correlated, that is, cov(ε1t, ε2t) 6= 0
I note: {Yt} and {Xt} should be second order weakly stationary or trend stationary

(we can include a deterministic trend in VAR)
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11.1 What Is Vector Autoregression (VAR)?

characteristics of a VAR system

1. only lagged values of {Yt} and {Xt} appear in the right-hand side of equations,
we do not include moving average (MA) terms (lagged values of ε1t and ε2t)

2. all equations in VAR contain same regressors, {Yt−1, . . . , Yt−p, Xt−1, . . . , Xt−p},
past history of {Xt} is allowed to affect the present value of {Yt}, and vice versa,
past history of {Yt} may affect the present value of {Xt}

3. order of the system is the largest number of lag p, it is common to all equations
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11.1 What Is Vector Autoregression (VAR)?

4. in general VAR may contain more than two variables - for example, in case of three
processes {Yt}, {Xt}, {Zt}, we will have three equations, each with regressors:
{Yt−1, Yt−2, . . . , Yt−p, Xt−1, Xt−2, . . . , Xt−p, Zt−1, Zt−2, . . . , Zt−p}

5. number of parameters increases very quickly with the number of lags and the
number of variables in the system
I in a VAR with 2 variables increasing order from p to p + 1 adds 4 parameters
I in a VAR with 3 variables, increasing order adds 9 parameters (3 parameters per equation)
I in general, with n variables the number of parameters increases by n2

VAR system can thus become overparameterized quickly, a large sample size is
needed to be able to estimate such a large number of parameters
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11.2 Estimation of VAR

I a common approach to choose the number of lags is to use the information criteria
I that is, estimate a VAR(p) for each value of p ≤ pmax and select the VAR(p∗)

such as p∗ minimizes the AIC or SIC
I each equation in a VAR can be estimated separately by an OLS
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Example: House Price Index in Los Angeles and Riverside MSAs

I time series of the quarterly house price index for two Metropolitan Statistical Areas
in California - Los Angeles and Riverside - about 60 miles apart
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Example: House Price Index in Los Angeles and Riverside MSAs

why consider both locations jointly and developing a VAR is the right approach
I economies of Los Angeles and Riverside are linked, thousands of people who

commute daily in both directions
I Los Angeles attracts many businesses in the manufacturing, entertainment, health,

education, and services industries
I Riverside has a smaller economy, benefits greatly from the economic activity in Los

Angeles area
I increased demand for housing in Los Angeles bids up real estate prices, causing

more people move to Riverside where real estate is cheaper which increases prices
there too
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Example: House Price Index in Los Angeles and Riverside MSAs

I the two time series for house price index and also for percentage changes in house
price index tend to move together

I time series for house price indexes are not second order weakly stationary, so we
will consider their percentage changes instead

I correlation coefficient for the two series in percentage changes is 0.84
I the collapse of the housing market bubble has been more dramatic in Riverside

(14.6% decline in 2008Q3, overall drop from peak 330 to 175) than in Los Angeles
(7.5% decline in 2008Q3, overall drop from peak 340 to 240)
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Example: House Price Index in Los Angeles and Riverside MSAs

I we thus estimate a VAR(1) for two endogenous variables - house price growth in
Los Angeles ghp_LA and in Riverside ghp_RI

Yt = c1 + α11Yt−1 + β11Xt−1 + ε1t

Xt = c2 + α21Yt−1 + β21Xt−1 + ε2t

I to estimate a VAR in EViews select Object → New Object → VAR and in the
VAR specification dialog select “Unrestricted VAR”, enter estimation sample,
provide names of the variables in “Endogenous Variables”, and the number of lags
in “Lag Intervals for Endogenous”

I in our example we choose 1975Q2 to 2009Q2 as estimation sample, leaving
2009Q3 to 2010Q2 as prediction sample for forecasting evaluation

I we also first consider the case with one lag only and so enter “1 1” in “Lag
Intervals for Endogenous”
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Example: House Price Index in Los Angeles and Riverside MSAs
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Example: House Price Index in Los Angeles and Riverside MSAs

I in the estimation output each column in the table corresponds to an equation in
the VAR

I our hypothesis that the real estate market in Riverside is very dependent on the
Los Angeles market is confirmed: since α21 = 0.8805 a 1 percentage point increase
in house prices in Los Angeles translates into a 0.88 percentage point growth of
house prices in Riverside

I on the contrary, the Los Angeles market does not seem to be affected by the
Riverside market: since β11 = 0.0719 and its t-statistics is smaller than 2 an
increase in the house prices in Riverside does not have a statistically significant
effect on house prices in Los Angeles
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Example: House Price Index in Los Angeles and Riverside MSAs
I we still need to verify whether one lag is sufficient or whether more lags are needed

to model the dynamics of the system
I SIC and AIC are helpful here - we choose the lag length by minimizing these

criteria as in the univariate case
I after estimating a VAR, select View → Lag Structure → Lag Length Criteria
I the optimal lag is denoted by an asterisk; in our example AIC and SIC agree on

choosing one lag as the optimal length of the VAR
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11.3 Granger Causality

I the main idea behind VARs is that a multivariate information set could be more
helpful than a univariate set in forecasting the variables of interest

I we could ask which among the variables in the information set and the VAR are
most useful to forecast others

I for example, suppose that for a process of interest {Yt} we have a multivariate
information set

It = {y0, y1, . . . , yt, x0, x1, . . . xt, z0, z1, . . . zt}

I we are interested in whether the information provided by time series {Xt} and
{Zt} is helpful to forecast future values of {Yt}
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11.3 Granger Causality

I Granger-causality: if some variable, for example, {Xt} does not help to predict
{Yt}, we say that {Xt} does not Granger-cause {Yt}

I a test of {Xt} not Granger causing {Yt} is performed by considering the equation
in VAR for variable Yt

Yt = c1+α11Yt−1+. . .+α1pYt−p+β11Xt−1+. . .+β1pXt−p+γ11Zt−1+. . .+γ1pZt−p+ε1t

and testing a joint hypothesis H0 : β11 = . . . = β1p = 0 against the alternative
H1 : β1i 6= 0 for some i ∈ {1, 2, . . . , p}

I if the test statistic exceeds the critical value (or equivalently if the associate
p-value is small) we reject the null hypothesis

I Granger-causality can be also tested for a group of variables: for example, we can
test that {Xt} and {Zt} do not help to predict {Yt} by performing the test with
joint hypothesis H0 : β11 = . . . = β1p = γ11 = . . . = γ1p = 0 against
H1 : β1i 6= 0 for some i ∈ {1, 2, . . . , p} or γ1i 6= 0 for some i ∈ {1, 2, . . . , p}
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Example: House Price Index in Los Angeles and Riverside MSAs

I going back to our data on house prices in Riverside and Los Angeles, we could ask
two questions:

1. Is the Riverside market Granger-causing the Los Angeles real estate market?
i.e. test whether {Xt} does not Granger-cause {Yt}, and the null hypotheses is
H0 : β11 = 0

2. Is the Los Angeles market Granger-causing the Riverside market?
i.e. test whether {Yt} does not Granger-cause {Xt}, and the null hypotheses is
H0 : α21 = 0

I to perform these tests in EViews after estimating a VAR, select View → Lag
Structure → Granger Causality/Block Exogeneity Tests
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Example: House Price Index in Los Angeles and Riverside MSAs
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Example: House Price Index in Los Angeles and Riverside MSAs

I when we examine the first equation, so test the effect of the Riverside market on
the Los Angeles market, we obtain a small value of the test statistic (1.178) and
large p-value (0.2776)

I this means that we fail to reject the null and conclude that the Riverside market
does not Granger-cause the Los Angeles market

I in other words, the Riverside market does not have predictive ability for the Los
Angeles market

I when we examine the second equation, in which we are testing the effect of the
Los Angeles market on the Riverside market, the value of the statistic is very large
(41.721) and the p-value is 0

I this means that we strongly reject the null hypothesis that changes in house prices
in Los Angeles does not Granger-cause changes in house prices in Riverside

I we conclude that the Los Angeles market has predictive ability for the Riverside
market

I this is additional evidence for our original hypothesis that the real estate sector in
Riverside depends highly on the Los Angeles sector
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11.4 Impulse-Response Functions

I a VAR allows us to track how shocks to one variable are transmitted to the other
variables in the system

I suppose that there is a shock to Los Angeles economy - an increase in the federal
defense spending that positively affects businesses in the area that work directly or
indirectly for the Department of Defense

I businesses in Los Angeles will increase the number of employees, this will increase
demand for houses in Los Angeles, which in turn increases their prices and provides
incentives for people to consider houses in Riverside instead, and that causes prices
of houses to rise there too

22 / 30



11.4 Impulse-Response Functions

I consider again the VAR(1) for growth of house prices in Los Angeles Yt and in
Riverside Xt

Yt = c1 + α11Yt−1 + β11Xt−1 + ε1t

Xt = c2 + α21Yt−1 + β21Xt−1 + ε2t

a positive shock ε1t will immediately increase Yt, which in next period increases
Yt+1, and also Xt+1

I then, an increase in Yt+1 causes an increase in Yt+2 and also Xt+2, in addition an
increase in Xt+1 causes an increase in YX+2 and also Yt+2

I this continues on for t+ 3, t+ 4, . . .. . .
I a shock to the i-th variable thus not only directly affects the i-th variable but is

also transmitted to all of the other endogenous variables through the dynamic (lag)
structure of the VAR
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11.4 Impulse-Response Functions

I the impulse-response functions (IRFs) measure the change in the variables of the
VAR over time after a one time shock

I formally impulse-response function is defined as
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≈
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I IRFs thus provides insight into the persistence and magnitude of the shocks
I it is common to set the size of the shock used to construct IRFs to 1 standard

deviation
I to obtain IRFs in EViews after estimating a VAR, either click on the Impulse

button, or select View → Impulse Response
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Example: House Price Index in Los Angeles and Riverside MSAs
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11.4 Impulse-Response Functions

I a problem arises when error terms ε1t and ε2t are correlated - IRFs assume that
only one shock occurs at a time

I solution to this problem is quite technical, errors terms ε1t and ε2t are transformed
in a certain way so that the covariance of transformed shocks will be zero

I from a practical point of view, the implication is that when error terms are highly
correlated ordering of variables in the VAR matters for the shape of IRFs
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11.4 Impulse-Response Functions

I in general, the choice of the ordering of the variables should be based on a prior
knowledge on the transmission of shocks - in a VAR a shock to variable i is
assumed to not have any contemporaneous effect on any variable ordered before it,
so j < i, it will only have a contemporaneous effect on any variable ordered after
it, so j > i

I in our example ordering (LA, RI) implies that shock in the Riverside housing
market does not have any contemporaneous effect in the Los Angeles market (but
effect may be coming in future periods) while a shock in the Los Angeles market
contemporaneously affects both Riverside and Los Angeles markets

I fortunately, ordering of variables in a VAR matters only for the IRS, for forecasting
purposes ordering does not matter
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11.5 Forecasting with VAR
I because every equation in the VAR has an autoregressive specification, forecast can

be constructed in a similar recursive way as for a univariate AR
I for example, for a two variable VAR(1)

Yt = c1 + α11Yt−1 + β11Xt−1 + ε1t

Xt = c2 + α21Yt−1 + β21Xt−1 + ε2t

under the quadratic loss function, f i
t,h = µi

t+h|t, so the 1 step ahead forecast is

fY
t,1 = c1 + α11Yt + β11Xt

fX
t,1 = c2 + α21Yt + β21Xt

2 step ahead forecast is

fY
t,2 = c1 + α11f

Y
t,1 + β11f

X
t,1

fX
t,2 = c2 + α21f

Y
t,1 + β21f

X
t,1

and in general, s step ahead forecast

fY
t,s = c1 + α11f

Y
t,s−1 + β11f

X
t,s−1

fX
t,s = c2 + α21f

Y
t,s−1 + β21f

X
t,s−1
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Example: House Price Index in Los Angeles and Riverside MSAs

I to construct a forecast for an estimated VAR in EViews click on Forecast button
or choose Proc → Forecast. . .

I the window that open then asks us to provide similar options as with univariate ARs
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Example: House Price Index in Los Angeles and Riverside MSAs
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